
Tremcards support 
 
Please note: Free of charge IT helpdesk and technical support is not provided to customers who have 
purchased a perpetual licence for their ADR 2007 Cefic Tremcards software.  Please see the 
Troubleshooting section for information on error messages and solutions to the most common software 
problems. 
 
IT support will be charged at our standard consultancy rates; please contact us for details. 
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Contents of the Tremcards CD 
 
There are five folders on the CD: 
 
Driver 
Contains the dongle driver for the Hasp dongle. You should not normally need to use this file. 
 
Files 
Contains the files for the complete Tremcards installation. You should not normally need to use these files. 
 
Install 
Contains the Tremcards installer program. If the CD does not autorun, you can start the Tremcards installer 
from this folder. 
 
Manual 
Contains installation instructions, plus reference material such as the Reference Table (which tells you which 
Tremcard you need for any UN number). 
 
Utils 
Contains utility programs for dealing with minor Tremcards issues. You should not normally need these files; 
if you do, the Troubleshooting section will tell you which to use. 
 
 

  



User-modified Tremcards 
 

1. Files that contain your user-modified Tremcards 
 
There are eight files that contain your user-modified Tremcards. They can all be found in the folder where 
the Tremcards program is installed – usually either on c:\Program Files\Tremcard or on a server. 
 
The files are: 
 
TREMPROD.DAT 
TREMPROD.IDX 
TREMRDTL.DAT 
TREMRDTL.IDX 
TREMRMST.DAT 
TREMRMST.IDX 
TREMUSER.DAT 
TREMUSER.IDX 
 
They may be listed without the file extensions (.DAT and .IDX). 
 
 

Installation issues 
 

1. Backing up user files 
 
Before you make any changes to the Tremcards installation, you should make a back up of your user files; if 
the upgrade or other change fails to work correctly, it will not be possible to repair the files and you will need 
the backed up copies. 
 
 

2. Installation as a new user 

 
There are installation instructions on the Tremcards CD, in the Manual folder. 
 
If you are putting Tremcards on a new PC, you should install it rather than just copying the files over from the 
old PC, because parts of the program (such as the fonts) need to be properly installed, and copying the files 
will not do that. 
 
 

3. Installing an upgrade 

 
This will not be relevant to most users – if you do need to run an upgrade, you should be sure to make a 
back up of your user files first. 
 
If the upgrade stops unexpectedly, you will need to delete the whole installation and then install Tremcards 
as new, because the user files will have become corrupted. If this is the case, you should first install the 
original version of Tremcards, then copy in your user files, then reboot the PC and then install the upgrade. 
 
 

4. Entering an activation key 

 
You will need Administrator rights on your PC in order to enter the activation key. If you are not sure whether 
you have these rights, you should check with your organisation's IT department. 
 
Entering the key: 
 

 Stop Tremcards 

 Click on Start > Programs > Cefic Tremcards > Enter Activation Key 

 The Activation Key program window will open 

 Enter your new Activation Key 

 Press the OK button when you have finished 



 The message 'REGISTRATION SUCCESSFUL!' should appear 

 Fill in the software registration form and click on Send to email it to the NCEC (or print and fax it). 

 Occasionally, an error message Error: AKTV05 – HTTP failure appears – this is nothing to worry 
about, but just means that your computer cannot talk to our email system. If you do get this error, 
you can close the message and carry on; we do not need to be notified since we already have your 
original registration. 

 
Checking that the key is working: 
 

 Start Tremcards 

 Select Help > About from the menu 

 The new expiry date (Expires: ) should be displayed 
 
 
If you cannot find the Activation Key program in your computer's Start menu, you can run it directly by 
browsing to the local Tremcards folder (usually c:\Program files\Tremcard) using Windows Explorer. Run the 
program ActivateTremcard in that folder, by double-clicking on it. 
 
 

Troubleshooting 
 
Error messages can look rather daunting, but most Tremcards problems are straightforward to sort out, so 
don't panic!  
 
If you are not very IT-literate you may prefer to ask your IT department for help. 
 
The single-user Tremcards program is usually installed to c:\Program Files\Tremcard. 
 
 

1. Error messages 

 
Introduction 
 
Most Tremcards error messages are in the form  STAMP! F=.\filename CT-XX  
 
like this one: 
 

 
 
 
The important bit for diagnosing the problem is the code at the end of the message (in this case, CT-12). 
 

 
 
 
There are also a few error messages that are formatted differently, with the code at the front. 



Index of error messages 
 
Click on the link to go to the relevant solution.  
 
Step-by-step instructions for opening the Tremcards folder on your PC or network 
 
Step-by-step instructions for opening the Tremcards CD 
 
CT-12 
The Tremcards program cannot find one of its files. 
 
This usually happens if some of the files are on a server, or if an installation has been made on a PC and 
then the files moved to a server. 
 
CT-14 
The user database has become corrupted. 
 
This generally happens when the Tremcards program is stopped by a power failure or PC crash, or if the 
user switches off their PC without exiting the Tremcards program. 
 
CT-16 
The Tremcards program cannot find one of its 'counter' files. 
 
There are two files that keep a count of how many users are running the Tremcards program. 
 
CT-17 
The user does not have correct permissions to access the Tremcards program. 
 
All users need full read/write access all the time, not just when installing the program. 
 
CT-1000 
There is more than one database date-stamp present in the Tremcards folder. 
 
This error usually occurs because the user has upgraded the Tremcards program and copied the user files 
into the upgraded installation. 
 
CT-54 
The Tremcards Print-Only program has not been provided with a copy of the main user's database.  
Tremcards needs a database to run and while the standard program creates its own when you first run it, the 
print-only version does not.  
 
E104 – Fatal Timer Problem 
The PC's clock has been altered to an earlier date, which means that the activation key will no longer work. 
This may happen after a virus infection. 
 
E108 – There are already X  users running this program. Contact your System Administrator. 
This usually happens because users have failed to shut down the Tremcards program correctly, or after a 
power failure while the Tremcards program was running. The 'counter' files will have been affected by that 
and will have an incorrect count of how many users are running the program. 
 
AKTV05 – HTTP failure 
The Activation Key program has not been able to 'talk' to the NCEC's email system. 
 
F072 – Failed to rename OLD SKEL 
This only occurs when trying to install (or upgrade) the Tremcards program over itself. 
 
HASP not found    (–3) 
The Tremcards program cannot 'see' the dongle. 
 
Some menu items are 'greyed out' 
The Tremcards program has a password in place and the user has not entered it correctly, or not entered a 
password at all. 
 



Solutions 
 
Step-by-step instructions for opening the Tremcards folder on your PC 
 

 Make sure that no part of Tremcards is running (i.e. make sure that you have closed any error 
message and/or problem report windows) 

 Click on Start > Programs > Accessories > Windows Explorer 

 Click on My Computer. You should see a list of folders and files on the right side of the window 
 
Either: 

 Double-click on the C: drive (which may be called Local Disk) 

 Find the folder Program Files and double-click on it. This will give you a list of files on the right side 
of the window 

Or: 

 Double-click on the drive letter for the server where your Tremcards data is kept (you may need to 
consult your organisation's IT department about this) 

 
 

 Find the Tremcard folder and double-click on it. This will give you a list of files (or icons) on the right 
side of the screen, something like this: 

 

 
 
 
 
Step-by-step instructions for opening the Tremcards CD 
 

 Make sure that no part of Tremcards is running (i.e. make sure that you have closed any error 
message and/or problem report windows) 

 Click on Start > Programs > Accessories > Windows Explorer 

 Put the Tremcards CD in your CD drive. It will auto-run and offer to start installing Tremcards – click 
on Cancel 

 In Windows Explorer, click on your CD drive (usually D) – you should then see a list of folders and 
files on the right side of the window 

 



CT-12 
 
If you run single-user Tremcards on a network, check that someone else is not already using the program. 
When someone is using the program it will 'lock out' any other attempts to use it. 
 
Check that the Tremcards database has not been moved (for example, someone may have moved the files 
while making a backup, instead of copying them). If so, you will either need to move the files back or edit the 
tremcard.ini file accordingly – see below. 
 
If you are still getting the error message you should check the tremcard.ini file and if necessary edit it so that 
the Tremcards program is looking in the right place for its data: 
 

 Look at the tremcard.ini file (usually in c:\Program Files\Tremcard) and see if there is a section there 
that contains a line something like DataPath=n:\server_name, like this: 

 

 
 

 If there is, make sure that it is the correct location for the Tremcards files 

 If not, edit the ini file so that it has a new section, like this: 
 
 [Database] 
 DataPath=XXXXX 
 
 where XXXXX is the location of your Tremcards files 
 

 Make sure that you do not leave any spaces anywhere except in the folder name 

 Click on File > Save 

 Start Tremcards 
 
 
 
 
 
 
 
 



CT-14 
The corrupted files can usually be repaired or rebuilt using a utility program which is included on the 
Tremcards CD, in the Utils folder. This utility is called TREMRBLD.EXE (and may be listed as just 
TREMRBLD). 
 

 Copy the rebuild program to the folder where your Tremcards files are kept 

 Double-click on TREMRBLD to run the program – you will see a DOS window open and possibly 
some text scrolling in the window, then the window will close (on some PCs this will be too fast to 
see anything other than a flicker) 

 Start Tremcards 
 
 
CT-16 
The Tremcards 'counter' files can be deleted, and the Tremcards program will then create new copies. 
 

 Make sure that no one is running the Tremcards program 

 Go to the Tremcards folder on your PC or server 

 Delete the one (or two) 'counter' files – TREMSESS.DAT and TREMSESS.IDX (which may both be 
listed as just TREMSESS) 

 The Tremcards program can now be re-started 
 
 
CT-17 
All users of the Tremcards program need to have full read/write access to the entire Tremcard folder at all 
times (not just when installing the program). 
 
You may need to check this with your organisation's IT department. 
 
 
CT-1000 
In order to repair the problem you will need to reinstall the upgrade. 
 

 Uninstall the version of Tremcards that you have just installed 

 Delete the Tremcard folder from either the local PC (usually c:\Program Files\Tremcard) or server 

 Install the previous version of Tremcards again 

 Copy the four database files into the Tremcard folder 

 Reboot the PC 

 Run the upgrade again but do not replace the database files afterwards 
 
 
CT-54 
If you already have a copy of the main Tremcards database, copy it into the Tremcards folder (usually 
c:\Program Files\Tremcard). If you do not have a copy, contact the person in charge of supplying you with a 
copy of the Tremcards database. 
 
NB - the program and database must be the same version, otherwise the program will still not run and you 
will get a CT-1000 message. 
 
 
E104 – Fatal Timer Problem 
The activation key must be reset, which can only be done by uninstalling and reinstalling the Tremcards 
program. 
 

 Make sure that you have a back up of your user files 

 Uninstall Tremcards 

 Delete the Tremcard folder from either the local PC (usually c:\Program Files\Tremcard) or server 

 Reboot the PC 

 Check that the PC's time and date are correct 

 Install Tremcards 

 Copy the four database files into the Tremcard folder 
 
 



E108 – There are already X  users running this program. Contact your System Administrator. 
This can be solved by deleting the 'counter' files, so that the Tremcards program can create new copies and 
reset itself. 
 

 Make sure that no one is running the Tremcards program 

 Go to the Tremcards folder on your PC or server 

 Delete the two 'counter' files – TREMSESS.DAT and TREMSESS.IDX (which may both be listed as 
just TREMSESS) 

 The Tremcards program can now be re-started 
 
 
F072 – Failed to rename OLD SKEL 
This only occurs when trying to install (or upgrade) the Tremcards program over itself. 
 
In order to repair the problem you will need to reinstall the upgrade. 
 

 Uninstall the version of Tremcards that you have just installed 

 Install the previous version of Tremcards again 

 Copy the four database files into the Tremcards folder 

 Reboot the PC 

 Run the upgrade again but do not replace the database files afterwards 
 
 
 

2. Dongles  

 
Dongles and Windows Vista 
 
If you are running Vista you may find that you need to upgrade your dongle driver. If so, you will need to 
consult the Support page at Aladdin's website: 
 
http://www.aladdin.com/support/hasp/hasp4/enduser.aspx  
 
If you are not sure which driver to download, you should consult your organisation's IT department. 
 
 
Error message 
 

 
 
If you get an error message saying 'HASP not found    (–3)', you should check that you have the dongle 
attached to the PC, and that it is fully secured (i.e. not loose). If you then still get the error message you 
should check whether you need to upgrade the dongle driver. 
 
 
 

 
 
 
 
 
 
 

http://www.aladdin.com/support/hasp/hasp4/enduser.aspx


3. Resetting or removing a password 

 
When the Tremcards program has a password set, users can still run the program without it but will find that 
many menu items are 'greyed out', like this: 
 

 
 
The password is stored in the user database files, in an encrypted form. This means that you cannot 'look up' 
the password if you forget it or need to find out what it is.  
 
There is a program on the Tremcards CD which will delete the password; you can then re-start Tremcards 
and re-enter a password. You may use the same password again if you wish. 
 
Deleting the password 
 

 Copy the utility KILLPASS.EXE (which may just be called KILLPASS) from the Utils folder on the 
Tremcards CD into the folder where the Tremcards program is installed 

 Double-click on KILLPASS.EXE to run the program 

 Start Tremcards 
 

Creating a new password 
 

 Start Tremcards 

 Click on File > Options 

 Enter a password in the appropriate field and click the green tick. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



4. Printing red bands on the Tremcard 
 
If you wish to print red bands on your Tremcards, you will need to select the correct option in the Tremcards 
program: 
 

 Start Tremcards 

 Click on File > Options 

 Check the box for Print Red Bands 

 Click the green tick 
 

 


